tvrtvr
Participant
    Post count: 13

    Hello asdfasdfasd,

    I’m sorry to hear resp. to read this.

    The show in the reported forum is going on.

    New Version of ETS 6.1.0 -> cracked version, only patches – compatibility mode not working (needed for older or converted databases from ETS 5.X.X)

    New Version of ETS 6.1.0 -> cracked version, only patches – compatibility mode now working!!!

    New Version of ETS 6.1.1 -> original Version (full setup) and cracked version (only patches) – two separate downloads.

    Have fun