Home Forums Gira HomeServer Echte Homeserver 4.9 Images (patched)

Viewing 15 posts - 1 through 15 (of 237 total)
  • Author
    Posts
  • sinn3r
    Participant
    Post count: 155

    Dieses Image basiert auf dem Original-HS-Image, keine “normale” Linux Installation mehr.
    Ich habe einige zusätzliche Treiber integriert, damit das Image auch in den gängigen Virtualisierern und auch etlichen physikalischen Boards läuft. Einfach eine virtuelle Maschine mit 2 x64-CPUs und 1GB RAM erstellen, das Festplattenimage als SATA-Laufwerk (wichtig) einbinden und fertig.
    Kein umständliches Fummeln mit BIOS-Editoren mehr! Seriennummer und Gerätename lassen sich in 2 Textdateien einfach ändern.
    Weiterhin läuft nun auch ein SSH-Server (im Unterschied zum Original-Image), somit ist ein Remote-Login z.B. zum Debuggen von Logikbausteinen oder auch zum Austausch von Dateien mittels SCP möglich.

    Hyper-V vhd:
    https://openload.co/f/4aCMQn2Zr6Y/hs49_v4_hv.7z

    VMware vmdk (growable VMware Workstation Format):
    https://openload.co/f/4FNkjpBymVQ/hs49_v4_vmw.7z
    Für ESXi muss das Image über die Workstation auf den ESXi hochgeladen werden, da das Format ein anderes ist.

    Experte Login:
    IP: 192.168.0.11
    User: admin
    Passwort: admin

    SSHD-Login:
    User: root
    Passwort: passwd

    Standardwerte:
    Seriennummer: 000AB3022955
    Board-Name: D3003

    Um die Seriennummer zu ändern gibt es 3 Möglichkeiten
    a) das Image in einem anderen Linux mounten (EXT4) und die Datei /hsdata/configuration/hs_4_product_serial editieren.
    Um den Gerätenamen anzupassen, die /hsdata/configuration/hs_4_product_name anpassen (nicht empfehlenswert).

    b) mit einem Hexeditor im Disk-Image nach “000AB3022955” suchen und entsprechend abändern.

    c) hat die VM eine gültige MAC Adresse, dann wird diese anstelle der im Image hinterlegten Seriennummer genutzt.

    d) über SSH am Homeserver anmelden und dann die Datei /flash/hsdata/configuration/hs_4_product_serial mit vi bearbeiten.

    Bitte ausführlich testen und Rückmeldung an mich.
    Und wie immer: Nur nutzen, wenn Ihr auch einen echten Homeserver zuhause habt!

    • This topic was modified 1 month ago by  sinn3r.
    • This topic was modified 1 month ago by  sinn3r.
    • This topic was modified 1 month ago by  sinn3r.
    • This topic was modified 3 weeks, 5 days ago by  sinn3r.
    • This topic was modified 3 weeks, 2 days ago by  sinn3r.
    • This topic was modified 2 weeks, 6 days ago by  sinn3r.
    • This topic was modified 2 weeks, 6 days ago by  sinn3r.
    • This topic was modified 2 weeks, 6 days ago by  sinn3r.
    ruby
    Participant
    Post count: 17
    sinn3r
    Participant
    Post count: 155

    @urs ich denke schon, lediglich die Netzwerkkarte wäre interessant.
    Treiber für Realtek, Intel e1000, und das alte und neue Hyper-V Netzwerk sind dabei.
    Sollte sogar auf jedem beliebigen 64-bit Board mit passender Netzwerkkarte laufen.

    ruby
    Participant
    Post count: 17
    kev
    Participant
    Post count: 20

    Warum nicht einfach änderbar über die MAC-Adresse der VM? :)

    Satjogi
    Participant
    Post count: 7

    ….Hier stand Blödsinn….

    • This reply was modified 1 month ago by  Satjogi.
    leo22986
    Participant
    Post count: 21

    Laufen nicht in VM Ware oder in Hyper V. Booten immer neu..

    Ich
    Participant
    Post count: 38

    Gibt es unter Netzwerk-Einstellungen bei VMware Workstation irgendetwas zu beachten ? Bekomme folgende Fehlermeldung:
    error: (Errno 101) Network ist unreachable

    • This reply was modified 1 month ago by  Ich.
    sinn3r
    Participant
    Post count: 155

    @ich:
    Ich nutze selber kein VMware und habe daher einfach nur mal den Intel e1000e Netzwertreiber eingebettet, den auch kev in seinem Image hatte.
    Das VMware-Diskimage ist einfach die konvertierte Hyper-V Disk.
    Findet er beim Booten denn die Netzwerkkarte?
    Ich habe auch ein ifconfig während des Bootens eingebaut, zeigt das eth0 an oder nur lo?

    • This reply was modified 1 month ago by  sinn3r.
    sinn3r
    Participant
    Post count: 155

    @leo22096 Bitte mal den Bootvorgang pausieren und eventuelle Fehler hier einstellen.
    Bei mir bootet das Image im Server 2016er Hyper-V (Gen 1 + neue Netzwerkkarte).

    sinn3r
    Participant
    Post count: 155

    @kev: weil dann die Leute mit physikalischen Boards wieder den Aufwand haben.

    Hendrik
    Participant
    Post count: 13

    Man darf bei der Erstellung der VM nicht SCSI als Interface nehmen.
    Ich habe SATA genommen und die VM bootet.
    Allerdings habe ich folgenden fehler:
    File "./../hs_main/dr.bcu2.py", line 287, in Main OS Error: [Errno 5] Input/Output error

    Ich
    Participant
    Post count: 38

    @leo22986
    Wenn die einen Bootloop hast, stimmen deine VMware Settings nicht. Wähle für die Konfiguration die erweiterten Einstellungen aus.
    Nimm bei Guest OS “Debian 9.x.64-bit” und ändere den Virtual Disk Type auf “SATA”. Füge abschließend die Virtual Disk von @sinn3r hinzu und boote die VM. Sollte dann ohne Loop starten.

    • This reply was modified 1 month ago by  Ich.
    Ich
    Participant
    Post count: 38

    @hendrik
    Was hast du als OS gewählt ? Ich erhalte noch einen eth0 Error, da die Netzwerkkarte bei Debian ens33 heißt.
    Das würde sich zwar fixen lassen, aber wenn es eine einfachere Lösung gibt.

    Hendrik
    Participant
    Post count: 13

    @ich
    Ich habe Debian 9.x 64 gewählt.
    Bekomme aber immer den selben Fehler.

    In meiner vmx steht als Netzwerk die ethernet0.virtualDev = “e1000” drin.
    Bekomme beim booten aber auch nur das loop Interface angezeigt.

Viewing 15 posts - 1 through 15 (of 237 total)
  • You must be logged in to reply to this topic.