Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • MarcT
    Participant
    Post count: 2

    Could somebody share a link to ETS 5.7 or higher again please?
    There is a link in ‘ETS5 5.7.2 Download’ topic, but this doesn’t work for me.
    I really need this because I bought some KNX components which are only compatible with ETS 5.7 or higher by mistake. (I have 5.6.6)
    Thanks

    MarcT
    Participant
    Post count: 2

    update;
    the link in the other thread to uploaded.net works again.
    before I had a message on the recaptcha ‘error site exceeds free monthly usage limit of reCAPTCHA’ or something like that.
    Today it just worked again for some reason.
    I openened the rar file with 7zip fiy.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.