shockzz
Participant
Post count: 2

Ok, I finally sorted it out … The VM was configured correctly, but anyhow I wasn’t able to get out of it. I configured the VMnet0 adapter to be bridged via the physical network adapter (I think I had some misconfiguration in which the auto bridge mode was connected to the network adapter of Virtual Box – since I am using Virtual Box as well on the same Host)… so if you may have the same troubles make sure you connected the Bridged adapter to the Host NIC.

Secondly I was able to reach all other machines within my network, but I wasn’t able to reach the internet .. anyhow I was able to reach the internet, but I had to change the DNS Server properly; therefore I edited /etc/resolv.conf and placed the GW in there. (then everything worked like charm)

The serial configuration wasn’t working because it seems “/hs/bin/hs_main trans” relies on having access to the serial adapter #0, but if there are two of them like in the tutorial the windows VM is properly connected to the linux VM, but nothing happens.
For debugging try using a Hyperterminal for the COM-ports on windows and write via Linux “echo HelloWorld > /dev/ttyS0” and check if it appears while monitoring with 9600 baud (for the other settings use the default) under COM1 hyperterminal.
The solution was to delete all COM ports for the Linux VM except the one with the pipe! So make sure you have a pipe with “this-side-is-the-client” on Linux VM and that you have the same one for the Windows VM with “this-side-is-the-server”.

1. Step after having that configured is to start the Linux VM and comment out the last line of /etc/inittab to prevent hs_main from starting.
2. Start the Windows VM and GIRA Experte, the transfer the project via COM-Port #1; it will notify you to reboot the Linux VM then.
3. Reboot the Linux VM
4. After Reboot is finished execute “/hs/bin/hs_main trans” and the transfer shall start!