Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • EIB_DIY
    Participant
    Post count: 1

    Hi.
    Here is my summary on how I built a working hardware box.

    Hardware :
    – a used Wyse J400 WT941GXL WinTerm thin client (must be one with a VIA CPU, some are with AMD !!!).
    – a 2GB female IDE 40-pin Disk-on-module flash drive (mine is from Transcend).
    – an old ISDN-PCI card with HFC-S PCI chip (not really needed but since I had it anyway …)
    – some PC133 RAM (2 x 512MB is the max)

    The Wyse WT941GXL is a nice start for this project as it is a real mini-PC with an original VIA EPIA motherboard (1 GHz C3 CPU) with 100% passive cooling and an on-board VIA Rhine VT6103 LAN chip.
    Used, it is also quite cheap to buy today.
    My Wyse box was the “luxe” version, so it came with 512 MB ram and a small hard drive of 40GB.
    The normal version comes with less ram and a small DOM (no HDD) : just add some ram if needed. Until today, I still have 512MB ram in mine.

    I removed the HDD from my Wyse box, so no moving parts anymore, like the original box.
    The power supply unit inside the Wyse box has two cables ready to give power to DOM’s but, I had to modify one of the cables as it wasn’t with the right connector for my 2GB DOM. The soldering iron was needed to modify it the right way but it was a quick and very easy work. Some heat-shrink tube was also handy to make it looking good.

    Now the config :
    In the BIOS settings, I load “Optimized settings”, then I modify this :
    – serial port : 3F8 irq 4
    – parallel port : Normal
    – no boot logo
    – pushing the power button shuts down immediately (no 4 sec wait)
    – all passwords disabled (by default, the BIOS from Wyse uses “Fireport” as admin password).
    I’m not sure what are the best settings for the “power management” section.
    N.B. Wyse uses a modified BIOS, I think it is possible to flash the latest “normal” BIOS from VIA but I didn’t tried this and have no idea what it could change (in good or bad…).

    The 2GB DOM is plugged into the first IDE slot, but set as “slave”.
    I used FreeDOS and “fdisk” to make 4 Primary DOS partitions :
    16MB (Active), 110MB, 870MB, 870MB. All 4 formatted in FAT.
    Install FreeDOS on drive C: (16MB) and make this partition bootable.
    Copy the firmware files (“DOLINUX.BAT, …) on drive D: ; I used firmware version 2.5.
    It is also the right time to copy the 2 nice utilities (read below) on drive C:.
    For what I tried, the easiest way for doing this is to use another IDE HDD/DOM, already formated and configured with FreeDOS and having all useful file copied on it.
    Plug this other HDD/DOM as secondary master and boot on it by changing the BIOS boot order. The advantage of doing it this way is that you are sure that the partition table on the 2GB DOM are correctly created regarding the disk geometry reported by the BIOS ; I’ve see strange things happening when the DOM was partitionned/formatted on one PC and then moved on another PC.
    Remeber that DOS has a weired way of giving drive letters when you have 2 HDDs on a computer :
    C: is the first primary DOS partition on the first HDD
    D: is the first primary DOS partition on the second HDD
    then all other DOS partitions form the first HDD
    and then all other DOS partitions form the second HDD
    Once you have created the 4 partions on the 2GB DOM, you must reboot before formating and copying, so it is MUCH easier if you only have one DOS partition on your temporary HDD (the one in secondary master IDE) :
    C: is your temporary
    D: will be your future C: (16MB)
    E: will be your future D: (110MB)
    etc.

    Now the “magical tour” :
    On the internet, you will find 2 very nice utilities (to be copied on a subdirectory of your C: drive …)
    The first one is “eeprom.exe” (and eeprom.txt), made by VIA to edit some settings on the LAN chipsets like the VT6103. I used version 3.14 of this utility, but some others do exist also.
    Search on the web with “VT6103” and “eeprom” as keywords …
    The usage is very simple : in DOS, type “eeprom.exe -km1 XXXXXXXXXXXX” where the X’s are your desired MAC address without “:” nor “-“.
    The other nice utility is “SMBCFG.EXE”.
    This is a menu driven utility made to read and MODIFY some information stored into your motherboard, like serial numbers for exemple. Those information are also used by DMIDECODE in Linux.
    I found 2 “serial number” strings empty in my Wyse box, so I filled both with my MAC address.
    Search on the web with “smbcfg.rar” and “biosrepair.com” as keywords …

    Remove the temporary HDD, close the Wyse box and restart … you should have a dos prompt soon.
    Use the 2 utilities.
    Reboot the box.
    Go to drive D: and type DOLINUX + enter, firmware 2.5 should start with NET NET NET …
    Push the power button twice to reboot.
    Now, all it take to start the firmware automatically is to edit the autoexec.bat file and, at the end, go to the D: drive and execute “DOLINUX.BAT”.

    When it is OK, make a very light config with the expert 2.5 (IP and KNX base settings, one “admin” user with password and rights set, …) and push the config into the box via serial port (you will need a null modm cable between your PC and the COM port of the Wyse box).
    After a reboot and a download, your box should restart with an IP address and be rechable via network.

    From that point, you can stop expert 2.5 and start expert 2.10.
    A firmware upgrade of the box to 2.10, via network, is working with one exception : “DOLINUX.BAT” has been replaced by “DOLINUX2.BAT”, so the AUTOEXEC.BAT file must be adapted.
    If your box keeps rebooting with firmware 2.10, then you should look for another MAC address and reuse the two nice utilities ; it is possible to stop DOS from playing the AUTOEXEC.BAT file if you push F5 (or another “F” key ???) at the right time, in order to get out of the infinite reboot loop.

    I didn’t try firmwares above 2.10 yet.

    wolfman4.0
    Participant
    Post count: 16

    Supported Hardware for HS3.0 and original Firmware (updateable)

    Via EPIA-M 6000
    Via EPIA-ML 6000
    as long as they have VT8235 or VT8237 southbridge (= VIA Rhine II network adapter)

    or

    an old Thin Client with that mainboard:
    Wyse WT941GXL
    IGEL 3/4 3210 compact
    IGEL 5/4 5210 lx premium
    Neoware CA10 E140 (via C3 version)

    you have to program/flash a new mac-adress “000ab….”
    get valid adress here:
    http://download.gira.de/data2/mac-adressen_netzteiltausch.pdf

    Krzys
    Participant
    Post count: 1

    Hi EIB_DIY,

    Have a couple of question since I am Newbe to HS. I have collected all necessary parts a ready to build my HS.

    – When you are installing FreeDos on 16MB partition what option you have selected. Partition is quite small?
    – Do you suggest I will do 2.5 first and upgrade to 2.10 or should I go straight to 2.10?

    Best
    K

    fisi
    Participant
    Post count: 1

    Hi,

    I have one problem with HS3. I wanted to upgrade the firmware but somehow screw it and now its not stating at all. I want to install firmware from rs232 but its not working and not sending the files, the erorrlevel1 appers. It seams that its not loading operation software.

    Can anybody help me or instruct how to install from the scratch HS3 ?

    i’em newbie to HS3 :(

    Best regards
    Fisi

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.