Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
    Posts
  • sharkx
    Participant
    Post count: 17

    Hallo,

    hat jemand mal in der Vmware die USB Schnittstelle zum laufen gebracht? Ich bekomme es nicht hin. Hab eine Merten USB Schnittstelle. Möchte ungern noch einen weiteren Eibd Prozess auf einer seperaten Hardware installieren.

    Funkstoerung
    Participant
    Post count: 28

    Merten USB Schnittstellen werden vom Homeserver nicht unterstützt.

    Müsstest also über eibd gehen. Das habe ich allerdings noch nicht geschafft.
    Geht wohl nur über Multicast.

    Wenn du dafür ein aktive Konfiguration parat hast wäre ich sehr dankbar.

    sharkx
    Participant
    Post count: 17

    Ich hatte vorher auf meinem Debian Eibd laufen damit ich den HS mit der Merten USB Schnittstelle bedienen konnte. Daß War mir mit dem Stromverbrauch zu heftig, daher nun auch die Anschaffung des Igel. Ich habe aber gehofft das der HS auch mit der Merten USB Schnittstelle läuft.

    Muss wohl doch irgendwann ein IP Router her.

    Funkstoerung
    Participant
    Post count: 28

    Kannst du mal was zur Konfiguration des Homeservers und EiBD schreiben?
    Ich hab das nicht hinbekommen das der HS darüber mit dem Bus kommuniziert.

    sharkx
    Participant
    Post count: 17

    Eibd installiert? findknxusb bekommst du die Adresse deiner USB Schnittstelle heraus. Starte eibd mit eibd -D -T -S -d -i –pid-file=/var/run/eibd.pid usb:4:2:1:0:0

    Wobei usb:4:2:1:0:0 die Adresse deiner Schnittstelle ist.

    Ich hatte mir damals dieses script geschrieben:

    #! /bin/sh
    ### BEGIN INIT INFO
    # Provides: eibd
    # Required-Start: $all
    # Required-Stop: $all
    # Default-Start: 2 3 4 5
    # Default-Stop: 0 1 6
    # Short-Description: Start eibd service at the end of boot
    # Description: This services is for communications with knx/eib.
    ### END INIT INFO
    
    PATH=/sbin:/usr/sbin:/bin:/usr/bin
    DESC="Description of the service"
    NAME=eibd
    DAEMON=/usr/bin/$NAME
    DAEMON_ARGS="-D -T -S -d -i --pid-file=/var/run/eibd.pid usb:4:2:1:0:0"
    PIDFILE=/var/run/$NAME.pid
    SCRIPTNAME=/etc/init.d/$NAME
    
    # Exit if the package is not installed
    [ -x "$DAEMON" ] || exit 0
    
    # Read configuration variable file if it is present
    [ -r /etc/default/$NAME ] && . /etc/default/$NAME
    
    # Load the VERBOSE setting and other rcS variables
    . /lib/init/vars.sh
    
    # Define LSB log_* functions.
    # Depend on lsb-base (>= 3.0-6) to ensure that this file is present.
    . /lib/lsb/init-functions
    
    #
    # Function that starts the daemon/service
    #
    do_start()
    {
    # Return
    # 0 if daemon has been started
    # 1 if daemon was already running
    # 2 if daemon could not be started
    start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON --test > /dev/null \
    || return 1
    start-stop-daemon --start --quiet --pidfile $PIDFILE --exec $DAEMON -- \
    $DAEMON_ARGS \
    || return 2
    # Add code here, if necessary, that waits for the process to be ready
    # to handle requests from services started subsequently which depend
    # on this one. As a last resort, sleep for some time.
    }
    #
    # Function that stops the daemon/service
    #
    do_stop()
    Funkstoerung
    Participant
    Post count: 28

    Hi, ja der EIBD läuft bei mir auf nem Raspberry PI und ersetzt quais die IP Schnittstelle.
    per groupswrite schalte ich alle Gruppenadressen einwandfrei.

    Was hast du im Experten unter Projekteinstellungen?
    EIBNet / IP
    Multicast 224.0.23.12
    Port 3671

    oder etwas anderes?

    ?

    sharkx
    Participant
    Post count: 17

    Die physikalische IP des Eibd noch eintragen. Dann dürfte es passen

    Funkstoerung
    Participant
    Post count: 28

    Hmm, die ist bei mir 0/0/0 was der HS nicht akzeptiert. Daher habe ich eine nicht belegte genommen.

    Anonsten muss ich

    sharkx
    Participant
    Post count: 17

    nimm mal die IP deiner eibd maschin als multicast

    Funkstoerung
    Participant
    Post count: 28

    Tja, bekomme immer die folgende Error Message: TypeError: af_inet address must be tuple not nonetype

    Im Knx Userforum hatte es wohl jemand gelöst, aber leider nicht geschrieben wie.

    http://knx-user-forum.de/knx-eib-forum/19162-licht-geht-nicht.html

    Ist schon merkwürdig, mit der ETS kann ich über die IP und Port des EIBD konfigurieren, aber der HS will mit den gleiche Einstellungen nicht.

    Kann mir jetzt nur noch vorstellen das es am multicast liegt. Vielleicht geht das bei meinem Switch nicht

    Funkstoerung
    Participant
    Post count: 28

    Tja, bekomme immer die folgende Error Message: TypeError: af_inet address must be tuple not nonetype

    Im Knx Userforum hatte es wohl jemand gelöst, aber leider nicht geschrieben wie.

    http://knx-user-forum.de/knx-eib-forum/19162-licht-geht-nicht.html

    Heini
    Participant
    Post count: 149

    Hallo Funkstoerung,
    Projekteinstellung passt, wichtig ist eibd mit Routing starten.

    Gruß Heini

    Funkstoerung
    Participant
    Post count: 28

    Hmm, also routing fehlte schon mal bei mir. Wenn ich aber versuche zu schalten sagt mir der HS: typeError:getsockaddrarg:AF_Inet adress must be tuple not NoneType

    sharkx
    Participant
    Post count: 17

    HS und eibd in gleicher?

    Heini
    Participant
    Post count: 149

    Hallo Funkstoerung, nutzt du deinen raspberry nur als KNX Gateway, wenn dem so ist installiere dir mal Smarthome.py hast dann auch direkt Schnittstelle zu 1-Wire und anderen Systemen ,ist ein fertiges Image.

Viewing 15 posts - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.