Home Forums Gira HomeServer Echte Homeserver 4.9 Images (patched)

Viewing 15 posts - 136 through 150 (of 404 total)
  • Author
    Posts
  • Opelpower
    Participant
    Post count: 39

    So, ich komme so nach und nach weiter.
    Muss ich denn bei den Boardnamen “/hsdata/configuration/hs_4_product_name” auch noch was anpassen?
    Dort steht ja D3003, der S920 heißt aber D3313. Spielt dies irgendeine Rolle?

    sinn3r
    Participant
    Post count: 291

    Geht beides, kannst Du also auch auf D3313 ändern.
    Der HS zeigt das ja an, ist dann vielleicht schöner.

    Mel
    Participant
    Post count: 40

    @Opelpower
    Kannst du kurz beschreiben, wie und mit welcher Software du vorgegangen bist um das Image zu erstellen, bzw. Auf die Platte zu bekommen?
    Welche Größe hatte das neue Image nach Fertigstellung?

    Meine Idee ist die, dass ich eine Step by Step Anleitung bastel, mit Screenshots, damit ahnungslose wie ich z.B. das auch hingekommen.

    Meine Hardware steckt noch in der Post, deshalb lese ich erstmal nur mit.

    Borastoni
    Participant
    Post count: 15

    Guten Morgen,

    bin immer noch dran den Treiber für den SATA Controller zu ergänzen.
    Ich habe ihn jetzt auch gefunden.
    Mein Problem ist nun das ich nicht die richtigen Befehle unter Debian finde um die initrd.gz entpacken zu können. Ebenso dann wieder die richtigen Befehle um die initrd.gz wieder erstellen zu können.

    Wäre da nochmal um einen Tipp dankbar.

    Borastoni
    Participant
    Post count: 15

    @Mel

    Also ich habe das ganze unter Windows gemacht, einfach die Platte auf die das Image soll per USB-Sata Controller oder direkt im PC an den Sata Anschluss.
    Dann mit dem besagten Tool: “HDD Raw Copy Tool” erst die Virtuelle Platte in den Datenträgerverwaltung eingehängt, im “HDD Raw Copy Tool” diese dann als source ausgefällt und als Target dann die neue Patte.
    Platte umklemmen und Booten. Ging immer ohne Probleme bei meinem 3003 Board.

    Opelpower
    Participant
    Post count: 39

    @mel

    Glaub mir, DASS ist genau auch das was ich mir wünschen würde.
    ABER bis jetzt läuft bei mir noch gar nichts, weil ich den S920 noch gar nicht habe.
    Ich bin auch immer hier fleißig am mitlesen und komme nach und nach dahinter wie es funktionieren könnte.
    Wenn ich die Software zum laufen kriege, können wir zusammen versuchen eine Anleitung zu schreiben.


    @sinn3r
    @hsdude: Es wäre schön wenn ihr evtl. noch alles etwas ausführlicher beschreiben könntet.
    Das was für Euch selbstverständlich ist, ist für andere User so wie meine Wenigkeit absolutes Neuland.
    Im 1. Post ist ja schon sehr gut beschrieben, wie man z.B. die Seriennummer anpassen kann, aber die eigentliche Prozedur wie man wirklich das Image auf einen “S XY” bekommt, könnte etwas ausführlicher sein!
    Nebenbei ein großes “DANKE” dass Ihr dieses Projekt überhaupt möglich macht!!!!!!!!!!

    • This reply was modified 2 years, 3 months ago by Opelpower.
    sinn3r
    Participant
    Post count: 291

    @Borastoni
    HS-Image in /mnt mounten, in Zielordner für das entpackte initrd wechseln.

    initrd entpacken:
    xz -dc > /mnt/boot0/initrd.gz | cpio -idmv

    initrd packen:
    find . | cpio --quiet --dereference -o -H newc | lzma -7 > /mnt/boot0/initrd.gz

    Welchen Treiber genau willst Du denn einbauen?

    • This reply was modified 2 years, 3 months ago by sinn3r.
    sinn3r
    Participant
    Post count: 291

    @opelpower
    Eigentlich geht es hier ja auch primär um die Virtualisierung des HS.
    Ansonsten hat Borastoni das ja schon super beschrieben.

    Borastoni
    Participant
    Post count: 15

    @sinn3r

    xz das wars, entpacken ging jetzt.
    Aber beim packen kommt folgende Fehlermeldung: “xz: –format=lzma: Datei oder Verzeichnis nicht gefunden”

    Der Treiber nennt sich “sata_mv”.

    Danke

    sinn3r
    Participant
    Post count: 291

    Ah, das Forum vergeigt die Zeichen, das — sind eigentlich zwei – hintereinander.

    sinn3r
    Participant
    Post count: 291

    Mach lieber
    find . | cpio --quiet --dereference -o -H newc | lzma -7 > /mnt/boot0/initrd.gz
    Hatte gerade eine Kernel Panic beim Packen mit xz

    • This reply was modified 2 years, 3 months ago by sinn3r.
    Borastoni
    Participant
    Post count: 15

    @sinn3r

    Hat geklappt super, vielen Dank nochmal.

    sinn3r
    Participant
    Post count: 291

    Neues Image verfügbar (v4):
    – eingebauter Dropbear SSH Server
    – mehr SATA Treiber, damit sollte das Board von Borastoni und viele andere nun auch direkt laufen, insofern der Netzwerktreiber auch im Image vorhanden ist.
    Download im ersten Post.
    Viel Spaß!

    Opelpower
    Participant
    Post count: 39

    Ich versuche momentan das Image mit Hilfe von Vmdk2Phys auf meine MSATA zu bekommen.
    Aber bei ca. 99% bricht er ab und sagt Error.
    Wenn ich die Datei *.vmdk mit dem Vmdk2Phys checke kommt ebenfalls bei ca. 99% ein Fehler.
    Ist die Datei evtl. beschädigt????

    Fehler

    NACHTRAG:
    Es wurde mir zwar angezeigt, dass nichts auf die MSATA geschrieben wurde, ABER
    es hat funktioniert!!!!!!!!!!!!!!

    Bin absolut begeistert!!
    Jetzt noch ein paar Sachen anpassen (wegen Update von 4.5 nach 4.9)
    und dann mal beobachten. Der QC läuft zumindest schon einmal

    Vielen Dank für Eure Arbeit

    • This reply was modified 2 years, 3 months ago by Opelpower.
    cico
    Participant
    Post count: 18

    Hi , new image “v4” ..unable to transfer project with Gira expert .. network error .. someone have the same issue ?

Viewing 15 posts - 136 through 150 (of 404 total)
  • You must be logged in to reply to this topic.